package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Nome: (.+)`)
var str = `a1in1iionia
Dados do cliente
Nome: Foo
E-mail: foo@bar.com.br
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}