re = /Nome: (.+)/m
str = 'a1in1iionia
Dados do cliente
Nome: Foo
E-mail: foo@bar.com.br
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end