// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Nome: (.+)").unwrap();
let string = "a1in1iionia
Dados do cliente
Nome: Foo
E-mail: foo@bar.com.br
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}