#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<![A-Za-z])\d*[.,]?\d+(?![a-zA-Z])"
Local $sString = "1" & @CRLF & _
"1,2" & @CRLF & _
"1.5-4 (matches 1.5 & 4 separately)" & @CRLF & _
"(1+3) (matches 1 & 3 separately)" & @CRLF & _
"=1;" & @CRLF & _
"FF3D" & @CRLF & _
"3deg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")