$re = '/(?<![A-Za-z])\d*[.,]?\d+(?![a-zA-Z])/m';
$str = '1
1,2
1.5-4 (matches 1.5 & 4 separately)
(1+3) (matches 1 & 3 separately)
=1;
FF3D
3deg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);