const regex = /(?<![A-Za-z])\d*[.,]?\d+(?![a-zA-Z])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<![A-Za-z])\\d*[.,]?\\d+(?![a-zA-Z])', 'gm')
const str = `1
1,2
1.5-4 (matches 1.5 & 4 separately)
(1+3) (matches 1 & 3 separately)
=1;
FF3D
3deg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}