using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"a.*?t";
string input = @"# Greedy, Lazy, and Possessive quantifier
Match:
/
a # Match a
.* # Match any character
t # Match t
/
greedy can be dangerous at times
r re regex
tttt aaaaa aattaatatatatttt atttatt ttat
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}