const regex = /a.*?t/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('a.*?t', 'gm')
const str = `# Greedy, Lazy, and Possessive quantifier
Match:
/
a # Match a
.* # Match any character
t # Match t
/
greedy can be dangerous at times
r re regex
tttt aaaaa aattaatatatatttt atttatt ttat
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}