import re
regex = re.compile(r"a.*?t", flags=re.MULTILINE)
test_str = ("# Greedy, Lazy, and Possessive quantifier\n\n"
"Match: \n"
" /\n"
" a # Match a\n"
" .* # Match any character\n"
" t # Match t\n"
" /\n\n"
"greedy can be dangerous at times\n\n"
"r re regex\n\n"
"tttt aaaaa aattaatatatatttt atttatt ttat\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")