#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[\w][A-Z]-\d\d\d"
Local $sString = "# Abbreviation (縮寫)" & @CRLF & _
"" & @CRLF & _
"#下方為測試文字區塊" & @CRLF & _
"AE-403" & @CRLF & _
"BK-201" & @CRLF & _
"Qb-666" & @CRLF & _
"AZ-404" & @CRLF & _
"ae-103" & @CRLF & _
"BK-201" & @CRLF & _
"qb-666" & @CRLF & _
"az-404" & @CRLF & _
"" & @CRLF & _
"#解釋:藍色部分就是透過規則/[\w][A-Z]-\d\d\d/所配對成功的文字。" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")