re = /[\w][A-Z]-\d\d\d/m
str = '# Abbreviation (縮寫)
#下方為測試文字區塊
AE-403
BK-201
Qb-666
AZ-404
ae-103
BK-201
qb-666
az-404
#解釋:藍色部分就是透過規則/[\\w][A-Z]-\\d\\d\\d/所配對成功的文字。
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end