using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\w][A-Z]-\d\d\d";
string input = @"# Abbreviation (縮寫)
#下方為測試文字區塊
AE-403
BK-201
Qb-666
AZ-404
ae-103
BK-201
qb-666
az-404
#解釋:藍色部分就是透過規則/[\w][A-Z]-\d\d\d/所配對成功的文字。
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}