#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d+\.a.."
Local $sString = "# Quantifier:+ 篇" & @CRLF & _
"" & @CRLF & _
"#下方為測試文字區塊" & @CRLF & _
"AE-403.jpg" & @CRLF & _
"BK-201.BMP" & @CRLF & _
"Qb-666.acg" & @CRLF & _
"AZ-404.qoo" & @CRLF & _
"ae-103.png" & @CRLF & _
"BK-201.svg" & @CRLF & _
"qb-666.ai" & @CRLF & _
"az-404.ai.tmp" & @CRLF & _
"qK-.ajpg" & @CRLF & _
"" & @CRLF & _
"#解釋:藍色部分就是透過規則/\d+\.a../所配對成功的文字。" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")