import re
regex = re.compile(r"\d+\.a..", flags=re.MULTILINE)
test_str = ("# Quantifier:+ 篇\n\n"
"#下方為測試文字區塊\n"
"AE-403.jpg\n"
"BK-201.BMP\n"
"Qb-666.acg\n"
"AZ-404.qoo\n"
"ae-103.png\n"
"BK-201.svg\n"
"qb-666.ai\n"
"az-404.ai.tmp\n"
"qK-.ajpg\n\n"
"#解釋:藍色部分就是透過規則/\\d+\\.a../所配對成功的文字。\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")