import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+\\.a..";
final String string = "# Quantifier:+ 篇\n\n"
+ "#下方為測試文字區塊\n"
+ "AE-403.jpg\n"
+ "BK-201.BMP\n"
+ "Qb-666.acg\n"
+ "AZ-404.qoo\n"
+ "ae-103.png\n"
+ "BK-201.svg\n"
+ "qb-666.ai\n"
+ "az-404.ai.tmp\n"
+ "qK-.ajpg\n\n"
+ "#解釋:藍色部分就是透過規則/\\d+\\.a../所配對成功的文字。\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}