#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*resolve).*\.(?:css|js|gif|jpeg|jpg|png|ico|cur|gz|svg|svgz|mp4|ogg|ogv|webm|htc)$"
Local $sString = "It should match the following URL:" & @CRLF & _
"" & @CRLF & _
"/media/cache/ps_product_admin_thumb/productimages/image.jpg" & @CRLF & _
"" & @CRLF & _
"But not the following:" & @CRLF & _
"" & @CRLF & _
"/media/cache/resolve/ps_product_admin_thumb/productimages/image.jpeg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")