$re = '/^(?!.*resolve).*\.(?:css|js|gif|jpeg|jpg|png|ico|cur|gz|svg|svgz|mp4|ogg|ogv|webm|htc)$/m';
$str = 'It should match the following URL:
/media/cache/ps_product_admin_thumb/productimages/image.jpg
But not the following:
/media/cache/resolve/ps_product_admin_thumb/productimages/image.jpeg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);