import re
regex = re.compile(r"^(?!.*resolve).*\.(?:css|js|gif|jpeg|jpg|png|ico|cur|gz|svg|svgz|mp4|ogg|ogv|webm|htc)$", flags=re.MULTILINE)
test_str = ("It should match the following URL:\n\n"
"/media/cache/ps_product_admin_thumb/productimages/image.jpg\n\n"
"But not the following:\n\n"
"/media/cache/resolve/ps_product_admin_thumb/productimages/image.jpeg")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")