using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(INC|PRB)\d{7}";
string input = @"INC0012345";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}