$re = '/(INC|PRB)\d{7}/m';
$str = 'INC0012345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);