package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(INC|PRB)\d{7}`)
var str = `INC0012345`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}