const regex = new RegExp('Mikołaj', 'gm')
const str = `W kościelnej liturgii oraz w zwyczajach ludowych Boże Narodzenie poprzedzone jest okresem trzytygodniowego oczekiwania (dokładnie czterech niedziel), zwanego adwentem. W tym okresie wierni biorą udział w roratach poświęconych Najświętszej Marii Pannie. Dawniej w niektórych regionach Polski wyplatało się także wieńce adwentowe, które w pierwszą niedzielę adwentu wieszało się w domu pod sufitem i zapalało na nim świeczkę. W każdą następną niedzielę dokładano kolejne świeczki. Tradycją stało się również pieczenie bożonarodzeniowych pierników, wykonywanie ozdób na choinkę oraz wysyłanie kart świątecznych z życzeniami do krewnych i znajomych. W okresie adwentowym 6 grudnia przypada dzień św. Mikołaja, kiedy to dzieci obdarowywane są drobnymi prezentami, wkładanymi do butów lub pod poduszki.
Przez cały adwent aż do Święta Trzech Króli (6 stycznia) w niektórych regionach Polski po wsiach chodzą „gwiazdorzy”, którzy śpiewają kolędy, recytują wiersze albo wystawiają herody inspirowane jasełkami[1]. `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}