import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https?://)?(w{3}.)?(.{1,})/(\\d{1,})(.cms)";
final String string = "https://timesofindia.indiatimes.com/india/with-focus-on-indo-pacific-india-australia-assert-need-for-stronger-defence-trade-ties/articleshow/98551278.cms\n"
+ "https://timesofindia.indiatimes.com/india/five-steps-to-fix-our-airports-ps-its-not-rocket-science/articleshow/96647017.cms\n"
+ "https://timesofindia.indiatimes.com/india/she-lost-six-organs-to-cancer-that-hasnt-stopped-her-from-living/articleshow/97724882.cms\n"
+ "https://timesofindia.indiatimes.com/india/why-india-us-can-be-a-good-tech-partnership/articleshow/97680052.cms\n"
+ "http://www.timesofindia.indiatimes.com/india/ballooning-options-to-spy/articleshow/97660486.cms\n"
+ "timesofindia.indiatimes.com/india/we-the-people-should-know-who-they-are/articleshow/97739545.cms";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}