re = /(https?:\/\/)?(w{3}.)?(.{1,})\/(\d{1,})(.cms)/m
str = 'https://timesofindia.indiatimes.com/india/with-focus-on-indo-pacific-india-australia-assert-need-for-stronger-defence-trade-ties/articleshow/98551278.cms
https://timesofindia.indiatimes.com/india/five-steps-to-fix-our-airports-ps-its-not-rocket-science/articleshow/96647017.cms
https://timesofindia.indiatimes.com/india/she-lost-six-organs-to-cancer-that-hasnt-stopped-her-from-living/articleshow/97724882.cms
https://timesofindia.indiatimes.com/india/why-india-us-can-be-a-good-tech-partnership/articleshow/97680052.cms
http://www.timesofindia.indiatimes.com/india/ballooning-options-to-spy/articleshow/97660486.cms
timesofindia.indiatimes.com/india/we-the-people-should-know-who-they-are/articleshow/97739545.cms'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end