import re
regex = re.compile(r"(https?://)?(w{3}.)?(.{1,})/(\d{1,})(.cms)", flags=re.MULTILINE)
test_str = ("https://timesofindia.indiatimes.com/india/with-focus-on-indo-pacific-india-australia-assert-need-for-stronger-defence-trade-ties/articleshow/98551278.cms\n"
"https://timesofindia.indiatimes.com/india/five-steps-to-fix-our-airports-ps-its-not-rocket-science/articleshow/96647017.cms\n"
"https://timesofindia.indiatimes.com/india/she-lost-six-organs-to-cancer-that-hasnt-stopped-her-from-living/articleshow/97724882.cms\n"
"https://timesofindia.indiatimes.com/india/why-india-us-can-be-a-good-tech-partnership/articleshow/97680052.cms\n"
"http://www.timesofindia.indiatimes.com/india/ballooning-options-to-spy/articleshow/97660486.cms\n"
"timesofindia.indiatimes.com/india/we-the-people-should-know-who-they-are/articleshow/97739545.cms")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")