import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?!rou\\w+(\\/\\w+){2,}).)*$";
final String string = "/fajwe/conv_1/routing/apwfe/afjwepfj\n"
+ "/fajwe/conv_2/routing/apwfe\n"
+ "/fajwe/conv_2/routing\n"
+ "/fajwe/conv_3/routing/apwfe/afjwepfj/awef\n"
+ "/fajwe/conv_4/routing/apwfe/afjwepfj/awef/0o09";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}