re = /^((?!rou\w+(\/\w+){2,}).)*$/m
str = '/fajwe/conv_1/routing/apwfe/afjwepfj
/fajwe/conv_2/routing/apwfe
/fajwe/conv_2/routing
/fajwe/conv_3/routing/apwfe/afjwepfj/awef
/fajwe/conv_4/routing/apwfe/afjwepfj/awef/0o09'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end