package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[([^][|]+)(?:\|([^][]+))?]`)
var str = `This is an example definition. Here is a link to [foo]. This is an [aliased link|bar].
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}