re = /\[([^][|]+)(?:\|([^][]+))?]/m
str = 'This is an example definition. Here is a link to [foo]. This is an [aliased link|bar].
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end