package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https?:\/\/vk\.com\/(\S*)`)
var str = `Это текст https://vk.com/gruppa а тут я пишу`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}