re = /https?:\/\/vk\.com\/(\S*)/m
str = 'Это текст https://vk.com/gruppa а тут я пишу'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end