$re = '/https?:\/\/vk\.com\/(\S*)/m';
$str = 'Это текст https://vk.com/gruppa а тут я пишу';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);