using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\((.*?),([^)]+)\) : (.+)";
string input = @"(sparker0i@outlook.com,sparker0i) : password";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}