$re = '/\((.*?),([^)]+)\) : (.+)/';
$str = '(sparker0i@outlook.com,sparker0i) : password';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);