re = /\((.*?),([^)]+)\) : (.+)/
str = '(sparker0i@outlook.com,sparker0i) : password'
# Print the match result
str.match(re) do |match|
puts match.to_s
end