using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Start(?:(?!Start|End)[\s\S])*?(Middle|Center)[\s\S]*?End";
string input = @"Start...End...Start...End...Start...Middle...End";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}