$re = '/Start(?:(?!Start|End)[\s\S])*?(Middle|Center)[\s\S]*?End/';
$str = 'Start...End...Start...End...Start...Middle...End';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);