re = /Start(?:(?!Start|End)[\s\S])*?(Middle|Center)[\s\S]*?End/
str = 'Start...End...Start...End...Start...Middle...End'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end