#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([\w]+)\(((\([^)]+\)),([^)]+))?\)"
Local $sString = "INSERT((5,elon,musk,0123456789,10000.00,analyst,abc10.gmail.com,200),employee)" & @CRLF & _
"INSERT((500,engineering,fortworth,1,50),department)" & @CRLF & _
"INSERT((50,1,tesla,1/1/20,6/1/20,0.8),project)" & @CRLF & _
"INSERT((20,bill,gates,0123456789,10000.00,programmer,abc10.microsoft.com,300),employee)" & @CRLF & _
"UPDATE((400,research,dallas-fortworth,1,50),department)" & @CRLF & _
"UPDATE((40,1,updatedDb,1/1/20,6/1/21,0.4),project)" & @CRLF & _
"UPDATE((999,bill,gates,0123456789,10000.00,programmer,abc10.microsoft.com,300),employee)" & @CRLF & _
"SELECT((500,engineering,abc,1,50),department)" & @CRLF & _
"SELECT((*,*,musk,*,*,*,*,*),employee)" & @CRLF & _
"SELECT((40,1,updatedDb,1/1/20,6/1/21,0.4),project)" & @CRLF & _
"SELECT((*,*,test,*,*,*,*,*),employee)" & @CRLF & _
"DELETE((30,3,empdb3,10/15/20,11/01/20,0.6),project)" & @CRLF & _
"DELETE((1000,*,*,*,*),department)" & @CRLF & _
"DELETE((999,bill,gates,0123456789,10000.00,programmer,abc10.microsoft.com,300),employee)" & @CRLF & _
"DISPLAY()" & @CRLF & _
"WRITE()"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")