# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([\w]+)\(((\([^)]+\)),([^)]+))?\)"
test_str = ("INSERT((5,elon,musk,0123456789,10000.00,analyst,abc10.gmail.com,200),employee)\n"
"INSERT((500,engineering,fortworth,1,50),department)\n"
"INSERT((50,1,tesla,1/1/20,6/1/20,0.8),project)\n"
"INSERT((20,bill,gates,0123456789,10000.00,programmer,abc10.microsoft.com,300),employee)\n"
"UPDATE((400,research,dallas-fortworth,1,50),department)\n"
"UPDATE((40,1,updatedDb,1/1/20,6/1/21,0.4),project)\n"
"UPDATE((999,bill,gates,0123456789,10000.00,programmer,abc10.microsoft.com,300),employee)\n"
"SELECT((500,engineering,abc,1,50),department)\n"
"SELECT((*,*,musk,*,*,*,*,*),employee)\n"
"SELECT((40,1,updatedDb,1/1/20,6/1/21,0.4),project)\n"
"SELECT((*,*,test,*,*,*,*,*),employee)\n"
"DELETE((30,3,empdb3,10/15/20,11/01/20,0.6),project)\n"
"DELETE((1000,*,*,*,*),department)\n"
"DELETE((999,bill,gates,0123456789,10000.00,programmer,abc10.microsoft.com,300),employee)\n"
"DISPLAY()\n"
"WRITE()")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.