import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\w]+)\\(((\\([^)]+\\)),([^)]+))?\\)";
final String string = "INSERT((5,elon,musk,0123456789,10000.00,analyst,abc10.gmail.com,200),employee)\n"
+ "INSERT((500,engineering,fortworth,1,50),department)\n"
+ "INSERT((50,1,tesla,1/1/20,6/1/20,0.8),project)\n"
+ "INSERT((20,bill,gates,0123456789,10000.00,programmer,abc10.microsoft.com,300),employee)\n"
+ "UPDATE((400,research,dallas-fortworth,1,50),department)\n"
+ "UPDATE((40,1,updatedDb,1/1/20,6/1/21,0.4),project)\n"
+ "UPDATE((999,bill,gates,0123456789,10000.00,programmer,abc10.microsoft.com,300),employee)\n"
+ "SELECT((500,engineering,abc,1,50),department)\n"
+ "SELECT((*,*,musk,*,*,*,*,*),employee)\n"
+ "SELECT((40,1,updatedDb,1/1/20,6/1/21,0.4),project)\n"
+ "SELECT((*,*,test,*,*,*,*,*),employee)\n"
+ "DELETE((30,3,empdb3,10/15/20,11/01/20,0.6),project)\n"
+ "DELETE((1000,*,*,*,*),department)\n"
+ "DELETE((999,bill,gates,0123456789,10000.00,programmer,abc10.microsoft.com,300),employee)\n"
+ "DISPLAY()\n"
+ "WRITE()";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}