use strict;
my $str = '10 mg/day
10 mg per kg
10 mg/d
10 mg/kg/day
10 mcg
10 units
10 mg BID
10 mg/day
0.075% Lotion
5%
';
my $regex = qr/[0-9]{1,4}[ ]{0,1}(mg)[\/]{0,1}(kg\/day|kg|day|d)|[0-9][ ]{0,1}(mcg|units|BID)|([0-9][0-9.]){0,1}[0-9]{1,3}[%]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}