// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[0-9]{1,4}[ ]{0,1}(mg)[\/]{0,1}(kg\/day|kg|day|d)|[0-9][ ]{0,1}(mcg|units|BID)|([0-9][0-9.]){0,1}[0-9]{1,3}[%]").unwrap();
let string = "10 mg/day
10 mg per kg
10 mg/d
10 mg/kg/day
10 mcg
10 units
10 mg BID
10 mg/day
0.075% Lotion
5%
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}