import re
regex = re.compile(r"[0-9]{1,4}[ ]{0,1}(mg)[\/]{0,1}(kg\/day|kg|day|d)|[0-9][ ]{0,1}(mcg|units|BID)|([0-9][0-9.]){0,1}[0-9]{1,3}[%]", flags=re.MULTILINE)
test_str = ("10 mg/day\n"
"10 mg per kg\n"
"10 mg/d\n"
"10 mg/kg/day\n"
"10 mcg\n"
"10 units\n"
"10 mg BID\n"
"10 mg/day\n"
"0.075% Lotion\n"
"5%\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")