package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^A-Za-z0-9]+`)
var str = `_<$abc$>_`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}