use strict;
my $str = '_<$abc$>_';
my $regex = qr/[^A-Za-z0-9]+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";