re = /(<foo>)(.*?)(<bar>)/m
str = 'This is some variable text
<foo> some stuff <Hello World> other stuff <bar>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end