re = /<(.*?)>/m
str = ' some stuff <Hello World> other stuff '
subst = '($1)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result