import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\()(.*), .*, .*\\d+, \\d{4}(?=\\))";
final String string = "Yuta Taki (滝 裕太, Taki Yuta, born August 29, 1999) is a Japanese football player.\n\n"
+ "Yuta Taki (John Smith, Taki Yuta, born August 29, 1999) is a Japanese football player.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}