const regex = /(?<=\()(.*), .*, .*\d+, \d{4}(?=\))/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\()(.*), .*, .*\\d+, \\d{4}(?=\\))', 'gmi')
const str = `Yuta Taki (滝 裕太, Taki Yuta, born August 29, 1999) is a Japanese football player.
Yuta Taki (John Smith, Taki Yuta, born August 29, 1999) is a Japanese football player.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}